Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
South African withdrawals are being processed as normal. You can view our withdrawal schedule here: https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted about 1 month ago. Dec 12, 2017 - 09:37 UTC
Monitoring
All withdrawals have been processed according to Luno's withdrawal schedule yesterday, Thursday, 07.12.2017.

You can view our withdrawal schedule on the following help page: https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted about 2 months ago. Dec 08, 2017 - 08:46 UTC
Investigating
There has been a delay in the processing of some withdrawals today. All pending withdrawals will be processed by tomorrow, Friday, 08.12.2017. The money should reflect in our customers' bank account at the latest 48 hours after the withdrawal has been processed. All customers will receive a confirmation email. We apologize for the inconvenience caused.
Posted about 2 months ago. Dec 07, 2017 - 14:40 UTC