No withdrawals processed on public holidays in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 27 days ago. Jun 19, 2018 - 07:26 UTC
Identified
We wish all our Nigerian customers a happy Eid.
No bank withdrawals will be processed on Friday, 15 June or Monday 18 June.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here:
https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted about 1 month ago. Jun 15, 2018 - 07:31 UTC