Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
All withdrawals are being processed again as per normal.
Posted about 1 month ago. Jan 16, 2018 - 07:29 UTC
Identified
There has been a delay in the processing of some withdrawals today. All pending withdrawals will be processed by tomorrow, Tuesday, 16.01.2018. The money should reflect in our customers' bank accounts at the latest 24 hours after the withdrawal has been processed. All affected customers will receive a confirmation email. We apologize for the inconvenience caused.
Posted about 1 month ago. Jan 15, 2018 - 15:55 UTC