Bank withdrawals to FNB in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 8 days ago. May 17, 2018 - 08:52 UTC
Identified
Due to a technical error with FNB we've been unable to process the latest batch of withdrawals to FNB customers. Withdrawals requested today should clear in FNB bank accounts tomorrow morning.

Updates to follow soon.
Posted 9 days ago. May 16, 2018 - 13:53 UTC