Bank withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 6 days ago. Jul 10, 2018 - 14:37 UTC
Identified
Due to a technical error with Mandiri Bank, some withdrawals made on Monday 9 July 2018 will be delayed. All further withdrawals should be processed as per our withdrawal schedule.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 7 days ago. Jul 09, 2018 - 15:28 UTC
This incident affected: Bank deposits and withdrawals (Indonesia).