Degraded performance on buy and sell orders
Incident Report for Luno
Resolved
Our team confirms that there are no longer any errors being generated, thanks for everyone's patience.
Posted 3 months ago. Mar 20, 2018 - 04:56 UTC
Identified
Some customers may see errors when trying to buy or sell digital currency, our team are investigating urgently.
Posted 3 months ago. Mar 20, 2018 - 04:36 UTC