Degraded performance
Incident Report for Luno
Resolved
System performance levels have returned to normal.
Posted about 1 month ago. Jan 18, 2018 - 15:55 UTC
Identified
Due to extreme market volatility, some systems are seeing degraded performance. Our engineers are aware and working to bring load levels back to normal.

This will affect the app, some website performance and the Exchange.
Updates to follow.
Posted about 1 month ago. Jan 17, 2018 - 15:02 UTC