Slow bank withdrawals in South Africa
Incident Report for Luno
Withdrawals are being processed as normal, thanks for everyone's patience.
Posted 20 days ago. Mar 02, 2018 - 06:59 UTC
There will be a slight delay with South African bank withdrawals requested on 1 March 2018. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here -

Updates to follow.
Posted 21 days ago. Mar 01, 2018 - 08:10 UTC