Delayed bank withdrawals to Standard Bank in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Feb 19, 2018 - 14:25 UTC
Identified
Withdrawals requested to Standard Bank this weekend have had to be routed via FNB as there is a technical issue with Standard Bank this morning.
This will result in slower than normal withdrawals to Standard Bank as bank clearance times will now apply.

We will resolve this incident once we can successfully release withdrawals via Standard Bank.
Posted 3 months ago. Feb 19, 2018 - 07:04 UTC