Delayed Ethereum sends and receives
Incident Report for Luno
Resolved
Ethereum send and receive transactions have returned to normal.
Posted 22 days ago. May 03, 2018 - 11:04 UTC
Monitoring
Customers are able to receive Ethereum as normal, sending Ethereum should return to normal shortly.
Updates to follow.

Thanks for everyone's patience.
Posted 22 days ago. May 03, 2018 - 07:34 UTC
Update
While Ethereum send and receive transactions remain to be slow some are being processed. Transaction times are expected to return to normal within 1-3 days.

Sincerely sorry for the inconvenience caused.
Posted 23 days ago. May 02, 2018 - 08:16 UTC
Identified
We've identified the cause of the issue, our team are continuing to work to resolve this as soon as possible.
This incident only affects Ethereum send and receive transactions, buying, selling or trading Ethereum is not affected.

Updates to follow shortly.
Posted 23 days ago. May 02, 2018 - 06:27 UTC
Investigating
We are experiencing issues with on-chain sends and receives. We expect that the current delays will be resolved within the next 24 hours. Ethereum buys and sells continue to be instant as per usual. Thank you for your patience.
Posted 24 days ago. May 01, 2018 - 09:57 UTC
This incident affected: Ethereum sends and receives.