Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals have resumed as per our withdrawal schedule.
Posted Dec 13, 2017 - 21:06 UTC
Investigating
There has been a delay in the processing of some withdrawals today. All pending withdrawals will be processed by tomorrow, Wednesday, 13.12.2017. The money should reflect in our customers' bank accounts at the latest 48 hours after the withdrawal has been processed. All affected customers will receive a confirmation email. We apologize for the inconvenience caused.
Posted Dec 12, 2017 - 15:22 UTC