No withdrawals processed on public holiday in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 28 days ago. Jun 18, 2018 - 13:01 UTC
Update
We are continuing to work on a fix for this issue.
Posted 28 days ago. Jun 18, 2018 - 13:01 UTC
Identified
We wish all our Malaysian customers a happy Eid.
No bank withdrawals will be processed on Friday, 15 June.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here:
https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted about 1 month ago. Jun 15, 2018 - 07:32 UTC