Degraded performance
Incident Report for Luno
Resolved
Performance across the site and the app has returned to normal.
Posted 3 months ago. Feb 23, 2018 - 14:42 UTC
Monitoring
We've identified the issue and have actively pushed a fix out. We'll continue to monitor performance closely.
Posted 3 months ago. Feb 23, 2018 - 14:29 UTC
Investigating
Some customers may experience degraded performance when using our site or the app.
Our team are working on this as a priority, sincere apologies for any inconvenience caused.
Posted 3 months ago. Feb 23, 2018 - 14:21 UTC